How To Install OverGrive 0n Ubuntu 16.04

To Install OverGrive on Ubuntu 16.04

 OverGrive is an open-source, Google Drive client for Linux. It has support for syncing multiple accounts, auto syncing local files, choosing the Google Driver folder to be used, converting Google Docs to Office File Formats for offline editing, and many more. It is so simple to install OverGrive on Ubuntu 16.04 and this article covers the ground on the same process. 

 

Installing OverGrive

In order to install OverGrive on Ubuntu, you should install gdebi in prior. So run the following command which installs gdebi to your Ubuntu machine.

root@linuxhelpubnt:~# apt-get install gdebi
Reading package lists... Done
Building dependency tree
Reading state information... Done
gdebi is already the newest version (0.9.5.7ubuntu1).
The following packages were automatically installed and are no longer required:
gnome-software-common libappindicator1 libboost-chrono1.58.0
libboost-program-options1.58.0 libboost-thread1.58.0 libdb4.8++
libevent-core-2.0-5 libevent-pthreads-2.0-5 libexpat1-dev libgtkspell3-3-0
libindicator7 libpython-all-dev libpython-dev libpython2.7-dev libqrencode3
libsodium18 libzmq5 python-all python-all-dev python-dev python-gi
python-pip python-pip-whl python-pkg-resources python-pyinotify
python-setuptools python-wheel python2.7-dev
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 586 not upgraded.

 

Once gdebi is installed, you shall fetch the OverGrive package by making use of the wget command in the following way. The link of the download package is used in the command.

root@linuxhelpubnt:~# wget https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive_3.2.3_all.deb
--2017-11-10 12:27:30-- https://www.thefanclub.co.za/sites/default/files/public/overgrive/overgrive_3.2.3_all.deb
Resolving www.thefanclub.co.za (www.thefanclub.co.za)... 88.198.7.171
Connecting to www.thefanclub.co.za (www.thefanclub.co.za)|88.198.7.171|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 95558 (93K) [application/x-debian-package]
Saving to: ‘overgrive_3.2.3_all.deb.1’

overgrive_3.2.3_all 100%[===================>] 93.32K 154KB/s in 0.6s

2017-11-10 12:27:32 (154 KB/s) - ‘overgrive_3.2.3_all.deb.1’ saved [95558/95558]

 

You shall proceed with the installation process once the file is downloaded. Run the following command which triggers the installation process.

root@linuxhelpubnt:~# gdebi overgrive_3.2.3_all.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done

Google Drive Client
Linux Google Drive desktop client.
Do you want to install the software package? [y/N]:y
Selecting previously unselected package overgrive.
(Reading database ... 179115 files and directories currently installed.)
Preparing to unpack overgrive_3.2.3_all.deb ...
Unpacking overgrive (3.2.3) ...
Setting up overgrive (3.2.3) ...
The directory '/home/user1/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/home/user1/.cache/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Requirement already up-to-date: google-api-python-client in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: six<2dev,>=1.6.1 in /usr/local/lib/python2.7/dist-packages (from google-api-python-client)
Requirement already up-to-date: uritemplate<4dev,>=3.0.0 in /usr/local/lib/python2.7/dist-packages (from google-api-python-client)
Requirement already up-to-date: oauth2client<5.0.0dev,>=1.5.0 in /usr/local/lib/python2.7/dist-packages (from google-api-python-client)
Requirement already up-to-date: httplib2<1dev,>=0.9.2 in /usr/local/lib/python2.7/dist-packages (from google-api-python-client)
Requirement already up-to-date: rsa>=3.1.4 in /usr/local/lib/python2.7/dist-packages (from oauth2client<5.0.0dev,>=1.5.0->google-api-python-client)
Requirement already up-to-date: pyasn1-modules>=0.0.5 in /usr/local/lib/python2.7/dist-packages (from oauth2client<5.0.0dev,>=1.5.0->google-api-python-client)
Requirement already up-to-date: pyasn1>=0.1.7 in /usr/local/lib/python2.7/dist-packages (from oauth2client<5.0.0dev,>=1.5.0->google-api-python-client)
You are using pip version 8.1.1, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160415-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for libglib2.0-0:amd64 (2.48.0-1ubuntu4) ...

 

Once the application is installed, you shall straight-away launch the installed application from your Ubuntu dashboard. Just type the name of OverGrive in the search field and click on the icon that appears.

Search

 

When the application appears you should click on the connect account option, which in turn connects to your google account. 

step 2

 

The Login page of your Google account appears now. Choose the account and proceed. 

login

 

 

A code is generated. Copy it to your application. 

copy

 

Paste the code in the Account field. Once the field is filled, the Validate option appears. 

Paste

 

Click on the Valiadate option, it takes you to the next stage. 

account

 

 

You should now open in tool bar for syncing. 

open tool

 

And then open your Google Drive Folder. 

drive folder

 

Now, your Google Drive window appears on your screen. 

tool bar

 

For syncing it with your google drive, click sync now option. 

to sync

 

Once it is done, your file has been synced. 

Sync

With this, the installation of OverGrive comes to an end. 

 


Thank you! for using Linux Help.

You find this tutorial helpful? Share with your friends to keep it alive.
For more help topics browse our website www.linuxhelp.com
Be the first to comment, we value your suggestions. For further queries please comment below.

Tags: Ubuntu
user image Author :  Jackson