pandora fms installation error

While installing server rpm I am facing following issue 

 

[root@linuxhelp1 Downloads]# rpm -ivh pandorafms_server-7.0NG.726-1.noarch.rpm
error: Failed dependencies:
    perl(HTTP::Request::Common) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(LWP::Simple) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(LWP::UserAgent) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(XML::Simple) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(XML::Twig) is needed by pandorafms_server-7.0NG.726-1.noarch
    net-snmp-utils is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(NetAddr::IP) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(IO::Socket::INET6) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(Net::Telnet) is needed by pandorafms_server-7.0NG.726-1.noarch
    nmap is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(JSON) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(Encode::Locale) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(Sys::Syslog) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(HTML::Entities) is needed by pandorafms_server-7.0NG.726-1.noarch
    perl(Geo::IP) is needed by pandorafms_server-7.0NG.726-1.noarch
Tags: RPM
user image Author :   niklaus
1

Do follow the steps given below

yum groupinstall Development Tools -y

yum install perl* nmap

yum install net-snmp-utils

wget http://dl.fedoraproject.org/pub/epel/7/x8664/Packages/p/perl-Geo-IP-1.43-3.el7.x8664.rpm

rpm -ivh perl-Geo-IP-1.43-3.el7.x86_64.rpm

Finally install

rpm -ivh pandorafms_server-7.0NG.726-1.noarch.rpm

user image
Gokul September 14, 2018
Add comment