The process /usr/local/bin/php artisan queue:work exceeded the timeout of 60 seconds

# php artisan queue:listen database

 

when i run this command the data is fetched in Database but it stopped with the following error.....

 

[SymfonyComponentProcessExceptionProcessTimedOutException]

  The process "'/usr/local/bin/php' 'artisan' queue:work 'database' --once --queue='default' --delay=0 --memory=128 --sleep=3 --tries=0 --env='local'" exceeded the timeout of 60 seconds.

 

Tags: Php Laravel
user image Author :   liam
1

check the maxexecutiontime in php.ini file and increase as required

user image
karthikeyankarthi January 31, 2017
Add comment
1

Instead of changing in php.ini file, run the command as follows,

#php artisan queue:listen database --timeout=0

when timeout parameter is set as 0, it wont stop...!!!

user image
jagan January 31, 2017
Add comment
0

At first there is 60 secs but after i have changed it to 360 secs, the same error exists........

user image
liam January 31, 2017
Add comment
0

Now working fine...thanku

user image
liam January 31, 2017
Add comment