cannot install rpm package

When i was try to install a RPM package it got some dependency package error

 

[root@ns1 ~]# rpm -Uvh mydns-mysql-1.1.0-1.i386.rpm
error: Failed dependencies:
    libc.so.6 is needed by mydns-mysql-1.1.0-1.i386
    libc.so.6(GLIBC_2.0) is needed by mydns-mysql-1.1.0-1.i386
    libc.so.6(GLIBC_2.1) is needed by mydns-mysql-1.1.0-1.i386
    libc.so.6(GLIBC_2.1.2) is needed by mydns-mysql-1.1.0-1.i386
    libc.so.6(GLIBC_2.2) is needed by mydns-mysql-1.1.0-1.i386
    libc.so.6(GLIBC_2.3) is needed by mydns-mysql-1.1.0-1.i386
    libcrypt.so.1 is needed by mydns-mysql-1.1.0-1.i386
    libm.so.6 is needed by mydns-mysql-1.1.0-1.i386
    libnsl.so.1 is needed by mydns-mysql-1.1.0-1.i386
    libnss_dns.so.2 is needed by mydns-mysql-1.1.0-1.i386
    libnss_files.so.2 is needed by mydns-mysql-1.1.0-1.i386
    libresolv.so.2 is needed by mydns-mysql-1.1.0-1.i386
    libz.so.1 is needed by mydns-mysql-1.1.0-1.i386
Tags: Linux RPM
user image Author :   albiejames
0

Try installing the same package using yum command, because yum will automatically resolve all the dependent packages for the package you require to install

user image
parthiban February 10, 2018
Add comment