0 {{postValue.vote_count}}

Looking for assistance with SNMP configuration

Hello all, I pretty new to linux, and we are deploying SNMP V2c.

I got SNMP installed but I am having some issues with configuration. I found a few guides and all give me errors on the same part.

agentAddress udp:161,udp6:[::1]:161
also tried: agentAddress udp: (with the servers IP:161)
rocommunity (community name)

Server IP and Community are copied from a windows server with this running as intended.

So I am clearly missing something as I get this error when i bounce the service after configuring:
Active: Failed (Result: exit-code) since Tue 2021-07-13 15:38:39 UTC; 2s ago

Also, how do I know what version im configuring? The SNMP download from what I could tell contains all versions of SNMP versions, and I need to config the one I need. None of the instructions i have read covered how to select which SNMP version.

OK, some further testing:

I have tried some further things, for agent address I have tried the ip for the Observium server it's supposed to be talking to, confirmed they can talk with a ping, so the 2 servers do see each other, tried also ip/24 with no change. Now instead of saying it failed to talk to which is what I got with the initial command, now it is saying the correct IP address but failed, "Failed with result: exit-code".
I have tried with and without the rocommunity6 line, and per other instructions I have tried setting IPs into the rocommunity lines without success.

Any advise?


Your Answer